Home » Support » Tutorials/Power Tips » UEStudio » Using the classviewer
IDM Power Tips

Using the classviewer

One of the most exciting and useful features of the Workspace Manager in UEStudio is the Classviewer. The Classviewer allows you to view a parsed representation of your project and quickly access classes, functions, variables, and more.

The Classviewer may be invoked in UEStudio by clicking on the Jump to Classviewer button in the Intellitip toolbar or by clicking on the Tags tab of the Workspace Manager, which will result in a parsed representation of the active project to be shown.

Using the Classviewer


Step 1: Create your project

Your files must be part of a project in order for the Classviewer to parse them. To create a project, go to Project->New Project/Workspace->Create New Project.

You are given two options for creating a new project, Create New Project and Create New Project using templates.

Create New Project

Create New Project allows you to specify the location and name of your project, as well as select the appropriate files for your project.

Create Project Using Templates

Create Project Using Templates allows you to specify your project name and location, and also creates basic (default) files for your project as well as configuring the compiler settings (if necessary).

For this tutorial, we will be creating a new project for some PHP files.

Using the Classviewer in UEStudio

UEStudio will prompt you to specify the location and name of your project file. After you've done this, you will need to specify your project settings. For the purposes of this tutorial, we will only add a couple of PHP files to our project.

To add files to your project, click the "Add File..." button under the Files/Folders tab. You can also add a folder, the currently active file in the editor, or all open files in the editor.

Using the Classviewer in UEStudio

Further project settings are available under the "Settings" and "Debug" tabs.


Step 2: Access the Classviewer in the Workspace Manager

After you've created your project, you can see all project files under the "Project" tab in the Workspace Manager, as shown in the screenshot below. If the Workspace Manager is is not open in the editor, you may open it by going to View->Views/Lists and selecting "Workspace Manager", or by pressing CTRL + U.

Using the Classviewer in UEStudio

Now that you've created your project and opened it in UEStudio, your files have been parsed which allows the Classviewer to populate with a representation of your active project.

We will access the Classviewer by clicking the "Tags" tab at the bottom of the Workspace Manager. You can also access the Classviewer by clicking on the Jump to Classviewer button in the Intellitip toolbar.

Using the Classviewer in UEStudio


Step 3: Using the Classviewer

You will see your classes listed as well as an expand/collapse box for each entry. Expand a class to view its functions, variables, etc. Hovering over the function or variable will show you its full parameters as well as its location in the project.

Using the Classviewer in UEStudio

To access your functions, classes, and variables in the Classviewer, right-click on the entry. You are given three different options.

Using the Classviewer in UEStudio

Go To Definition

Selecting the "Go To Definition" option from the right-click context menu in the Classviewer will take you to the actual location of the entry in your project. UEStudio will open the necessary file for this if it is not already open.

Find Symbol in Active Document

This option will search for the symbol in the currently active document. The results of the search will be written to the tabbed output window. You may double-click on the filepath in the output window in order to see the symbol in the file.

Find Symbol in Project Files

This option will search for the symbol in all project files. The results of the search will be written to the tabbed output window. You may double-click on the filepath in the output window in order to see the symbol in the file.


Back to power tips index


Buy Now
Upgrade
Download

Get your solution today!

UEStudio/UltraCompare Solution

Add UltraCompare to your purchase/upgrade of UEStudio and complete your file management solution.

Existing UltraEdit users
UltraEdit to UEStudio

Upgrade from UltraEdit

to UEStudio and...

...receive a $30 credit!