Home » Support » Tutorials/Power Tips » UltraCompare » Compare large files
IDM Power Tips

Compare large files in UltraCompare Professional

UltraCompare is a very robust file comparison tool which includes support for comparing large files - even multi-gigabyte files. In fact, there is no hard-coded limit on the file size that UltraCompare supports - you are only limited by your system resources (memory, virtual memory, and disk space).

If you are trying to compare large files in UltraCompare you may see that this takes quite some time. There are several changes you can make to UltraCompare's configuration to improve speed and performance when comparing large files. We'll look at these step-by-step below.

1. Disable Relational Lines Mode

When relational lines mode is enabled, UltraCompare will attempt to logically "relate" your lines to compare lines that match up in both (or all three) files. Normally, UltraCompare will compare the files line-by-line for differences, but with relational lines mode enabled, UltraCompare attempts to find matches between the content of the compared files and exclude this from the difference comparison while indicating related blocks and the differences between them visually. Obviously this "smarter" compare mechanism requires more memory. When working with large files you can save memory/compare time by disabling this in the View menu.

2. Disable Line Numbers

Just like UltraEdit, UltraCompare will by default display line numbers for files. For large files, collecting and updating the line numbers can slow down your compare time or navigation. Disable line numbers by going to View -> Show Line Numbers.

3. Disable All Ignore Options

Ignore options allow you to ignore data that may be different between files that isn't necessarily important to you, such as blank lines, whitespace, line terminators, etc. These, however, do require more memory, so if you are comparing large files, you will want to disable them. You can access ignore options in Options -> Configuration -> Ignore Options -> Text.

4. Use Scrollable Map Instead of Scaled Map

The scaled/scrollable map is the white column on the left of the application window. If you're using the scaled map, UltraCompare will proportionally display the differences of your two files within the viewable area of the map (with no scrollbars) as opposed to mapping out differences in a scrollable fashion where no proportional math is used to represent them. Use the scrollable map with large files to conserve memory and processing when working with large files. If it is not already enabled, you can select the scrollable map by right-clicking the map. You can also access this option in Options -> Configuration -> Compare -> Text.

5. Disable Character Highlighting

By default UltraCompare will highlight specific differing characters within difference blocks in both (or all three) of your files. Disabling this will speed up the compare processing; you can disable different character highlighting by going to Options -> Configuration -> Compare -> Text and unchecking Disable character highlighting.

6. Increase Your System's Virtual Memory

UltraCompare uses your system's virtual memory to create internal compare tables for the files you are comparing. By increasing the amount of virtual memory available on your system, you can help improve performance for large file comparisons in UltraCompare. For more information, visit our step-by-step tutorial for increasing virtual memory on your system.


Back to power tips index


Buy Now
Upgrade
Download

Get your solution today!

Save when you bundle and complete your solution.

Application Screenshots

Screenshots

Portable Apps

Unleash the power of the total file management solution on your flash drive!

Still not using UltraCompare Pro?

Pro vs. Lite