Home » Support » Tutorials/Power Tips » UltraCompare » Export/save text compare output

IDM PowerTips

Export and save text compare output

UltraCompare Professional allows you to export and save your compare output as a results file. The following power tip will demonstrate the options available for difference reporting.

Export/Save Text Compare Output

If you are comparing files, and need to see the amount of differences between the files you are comparing, you can simply use the Difference Summary report.

If however you need a more comprehensive report, you may want to generate a result file. You can configure UltraCompare Professional to save and export compare results in Options->Configuration->Backup & Save. There are three options for the output result file format:

- Side-by-side format
- Differences in context
- Display the compare results for one frame only.


Difference Summary

For an overview of the differences between the files, go to View menu and click on the Difference Summary option.

The difference summary dialog is presented that summarizes the number of blocks and lines that are different between the two files being compared. The difference summary for the Folder Compare would of course summarize file and subdirectory differences in compared folders.

Export/Save Text Compare Output

Side By Side output format

If you require a comprehensive result file, The first option in Options->Configuration->Backup & Save, the side-by-side result, will output the compare result file much like the compare window you see in UltraCompare Professional. The two files will be written to the file side by side, and the differences will be indicated on the left.

Export/Save Text Compare Output

To save the compare result file, go to File->Save Result.

Export/Save Text Compare Output

Once you have saved your file, you can open it in UltraEdit to view the results.

The difference notation is as follows:

  • * - indicates that data is different between the compared files on the indicated line
  • <! - indicates that data is in the left file but not the right file
  • !> - indicates that data is in the right file but not the left file

For a Power Tip on running UltraCompare Professional and saving a result file from the command line, click here.


Differences In Context output format

The second option in the Options->Configuration->Backup & Save is the "differences in context" method. This will only show differences for the active pane of currently compared files. This limited result will obey the selected compare options (All, Just Differences, Just Matching).

Export/Save Text Compare Output

As shown in the screenshot below, the following symbols are used for the "differences in context" result:

+++ identifies the file in the first pane and
--- identifies the file in the second pane.

Along these lines, a + indicates text from the file in the first pane, and a - indicates text from the file in the second pane.

Export/Save Text Compare Output

Finally, the string @@ +1,6 -1,7 @@, as shown in the bottom screenshot, indicates that the differenced text begins on line 1 in the first pane and line 1 in the second pane, and that the number of lines including differences for the first file is 6, while the number of lines including differences for the second file is 7.

Export/Save Text Compare Output


Result For One Frame Only output format

The last option in the Options->Configuration->Backup & Save, "result for one frame only," will produce a formatted result file similar to the side-by-side result, except it will include only the contents for the active file.

Export/Save Text Compare Output

Export/Save Text Compare Output