Home » Support » Tutorials/Power Tips » UltraEdit for Linux » Keyboard shortcuts
IDM Power Tips

Keyboard Shortcuts

UltraEdit for Linux includes several different key mapping modes, including Gnome, KDE, or Windows defaults, as well as limited Emacs key mapping support. (Please note that for each mode, that mode's key mappings are respected when possible. The entire key mapping set (for instance, for Emacs) may not be completely available within the scope of UltraEdit for Linux.)

Beyond this, you can even customize these key mapping modes to suit your preferences and needs and maximize your efficiency and speed of navigation in UltraEdit. You can acess key mapping configuration in Edit -> Preferences -> Key Mapping. Here you are provided a drop down list for several different key mapping modes, and you can also set your own custom key mappings here as well.

Please note, the shortcuts listed here are default shortcuts, feel free to customize your shortcuts as you would like.

The following lists provide the default key mappings for Windows mode. This mode closely emulates the default key mappings for UltraEdit (Windows).

Document Navigation Shortcuts
F4 Toggle focus between active file and Tree View if shown
Ctrl+F6 Make the next document window active
Ctrl+Shift+F6 Make the previous document window active

Select/Delete/Insert Shortcuts
Ctrl+Left+Shift (or Right) Selects the word preceding (or following) the cursor
INS Toggle between Insert and Overstrike mode

Hex Mode Shortcuts
Ctrl+H Toggle HEX editing mode
Ctrl+D Insert or delete characters in HEX editing mode

Bookmark Shortcut
Ctrl+F2 Toggle bookmark on and off
F2 Goto next bookmark

File Menu
Ctrl+N Create a new document file
Ctrl+O Open an existing document file
Ctrl+Q Open an existing document without showing File Open dialog
Ctrl+F4 Close an existing document file
Ctrl+S Save the active document
F12 Save the active document as a new file
Ctrl+P Print the active document

Edit Menu
Ctrl+X Cut text from the document into the clipboard
Ctrl+C Copy text from the document into the clipboard
Ctrl+V Paste text from the clipboard into the active document
Ctrl+0-9 Select active clipboard
Ctrl+A Select All text in the active document
Ctrl+Z Undo the last action if possible
Ctrl+Y Reverse the last Undo action if possible
Ctrl+J Select the current word (same as double click)
Ctrl+E Delete line the cursor is on
Ctrl+F11 Delete from the cursor to start of line
Ctrl+F12 Delete from the cursor to end of line
Ctrl+W Toggle Word Wrap on/off
F7 Insert time/date at cursor

Search Menu
Ctrl+F Find a character string
Ctrl+F3 Repeat last find toward beginning of file
F3 Repeat last find toward end of file
Ctrl+B Find matching brace (,[,{ or },],)
Ctrl+R Find and replace a character string with another
Ctrl+G Goto the specified line (or HEX address)

Project Menu
Alt+0-9Insert template (0-9)

Project Menu
Shift+Alt+OOpen Project/Workspace
Shift+Alt+CClose Project/Workspace
Shift+Alt+SProject Settings

View Menu
Ctrl+U Toggle File Tree View

Format Menu
Ctrl+F5 Convert selected text to lower case
ALT+F5 Convert selected text to Upper case
F5 Capitalize first character of each word in selected text
Shift+Alt+F5 Invert case of all characters in selected text

Column Menu
ALT+C Toggle column/block mode on and off

Macro Menu
Shift+Ctrl+RMacro quick record
Ctrl+M Replay a macro
Ctrl+L Replay a macro the specified number of times

Script Menu
Shift+Ctrl+Z Show scripts

Help Menu

F1 Invoke help

Back to power tips index


Download
Upgrade
Buy Now

Get your solution today!

UE/UC

Add UltraCompare to your purchase/upgrade of UltraEdit and complete your file management solution.

Your bundle license runs on Windows, Mac, and Linux.

Using a different distribution? No problem!

Get UltraEdit for Linux on any distribution with our universal .tar download...

IDM Highlights newsletter

Sign up now for...

  • Software Powertips
  • New Releases
  • Update Notices
  • Cool Tools, Specials
  • Company News