Home  »  Support  »  FAQ
IDM Computer Solutions frequently asked questions

IDM Computer Solutions frequently asked questions

If you do not see your question here, and you are unable to find an answer in our power tips, or by using the search box, please email us with your question.

Click on a question to expand the answer

Show all  Hide all

Do I need to uninstall UltraEdit before installing an update or upgrade?

We suggest overwriting the existing installation of UltraEdit without uninstalling. This will maintain your current INI settings. You will be prompted as to whether or not you wish to overwrite your wordfile(s), and possibly your toolbars and menus. If your wordfile(s) are overwritten and you later wish to use your old wordfile(s), they are backed up in your %APPDATA% directory.

How can I download a previous or older version of UltraEdit?

Access to previous versions of UltraEdit (as well as UEStudio, UltraCompare, and UltraSentry) is only available through email. Please email us at support@ultraedit.com with your most current license information and we will be happy to assist you in accessing the version you need.

Why does the installation hang or not work?

This typically occurs with older installers (prior to v11.20b) which relied on DLLs provided by Internet Explorer 6. When Internet Explorer 7 was released, these DLLs were no longer available, which caused some installers for previous versions to not function at all.

If you are using Internet Explorer version 7 or greater and your installer is not working, please email us at support@ultraedit.com with your current registration information so we can assist you in working around this issue.

How can I delete blank lines with or without blank tabs/spaces in UltraEdit?

Please see our power tip on how to accomplish this.

Why does UltraEdit keep asking if I want to convert Unix files to DOS?

This prompt is related to the line terminators (endings) in the file you are opening. When you open a file that has been created on a Unix/Linux or Macintosh system, it may have different line terminators than a file created on a DOS(Windows)-based system. When you see this prompt, UltraEdit has detected Unix or Mac line terminators, and the prompt is asking you if you want to convert the line terminators to match DOS-based line terminators.

UltraEdit can handle and display Unix/Mac line terminators without any problems, but other Windows applications may have problems (for instance the lines may all run together or the line breaks may not display properly). By converting the file you will avoid these potential issues on Windows systems.

If you go to Advanced -> Configuration -> File Handling -> DOS/UNIX/MAC Handling and choose "Disable" for the "Unix/Mac file detection/conversion" setting this will not happen, or you can leave it set and if you want the file saved as DOS format you can disable the setting "Save file as input format". Additionally you can manually convert the file from the File menu.

I click "Yes" to the conversion prompt to convert from Unix/Mac to DOS when I open a file, yet the file conversion does not seem to work completely or at all. Why is this occurring?

UltraEdit only converts the file if it is edited and then saved. Also, if you have "Save file as input format" selected in the Advanced configuration menu, the conversion is overridden on save.

The primary purpose behind the automatic/dialog-prompt conversion on file open is to allow the Windows clipboard to function properly. With conversion enabled, a copy or cut operation will include DOS line endings (0D 0A), which allows for seamless use of Unix/Mac files in a DOS environment. The easiest way to get intuitive behavior is to disable the "Save file as input format" option.

How can I configure UltraEdit to create only Unix format files?

Version 11.20 and later:

You can access this setting by going to Advanced -> Configuration -> File Handling -> DOS/UNIX/MAC Handling. Select "UNIX" as the "Default file type for new files".

Prior to v11.20:

There is a DOS/UNIX/MAC Handling topic under the File Handling branch under Configuration in the Advanced menu to allow specification of the default format for new files created in UltraEdit. Under "Default file type for new files" you may select either "DOS", "UNIX", or "MAC" and new files would be created with the appropriate line terminators.

How can I disable the prompt about opening a file without a temp file?

By default a confirmation dialog is shown when editing files without a temporary file as there is no backup made and all changes are permanent. If you wish you may disable this under the Temporary Files topic in the File Handling branch under Configuration in the Advanced menu by selecting "Open file without temp file but NO Prompt".

Almost every time I open a file, I see this message: "In order to view the document correctly, you may have to change your font and/or script settings in the Font Dialog." How can I make this go away permanently?

This prompt is related to your font and script settings and the code page you are using. You can disable this prompt by going to Advanced -> Configuration -> File Handling -> Code Page Detection. Uncheck the option "Prompt to change font and script if different from default system code page".

Why do non-standard encoded characters (such as Japanese, Turkish, Korean, etc.) not display properly in UltraEdit?

There are 4 things you should check to ensure that your text displays with the proper encoding and characters:

1. Code Page. To set this, go to View -> Set Code Page. You should know which code page was used to create the text you're looking at - for instance, if you are looking at Japanese characters, your code page would most likely be 932 (Shift-JIS).

2. Font selection. You need to make sure you have selected a font that supports the non-standard characters. You can check this by going to View -> Set Font. Arial Unicode or Courier New are good choices.

3. Script setting. Your script setting must be correct as well. The font's script setting is accessible in View -> Set Font. Modify this setting at the bottom of this dialog, and make sure the selected script corresponds to the type of characters in your file.

4. OEM. Make sure that you are not using the OEM character set in View -> Set Font. This uses a different character set than standard fonts.

Also see the power tip about Unicode encoding in UltraEdit/UEStudio.

Why do Japanese, Chinese, Korean, or other eastern script characters appear rotated 90 degrees?

Are you using a Unicode font preceded by "@"? As indicated on Microsoft's site:

"Arial, Times New Roman, and Helvetica fonts work well with English characters and most European characters, but not with Japanese characters. The Japanese fonts that have font names starting with '@' are vertical fonts, meaning they are designed specifically for vertical writing (writing from top to bottom and right to left)."

"@" fonts are not suitable for English (or other languages) where writing is horizontal (left to right). Switch to a Unicode font not preceded by the "@" symbol under View -> Set Font.

How can I do a multi-line Find/Replace in UltraEdit?

Version 14 of UltraEdit and 06.50 of UEStudio include a new multiline find and replace dialog.

Prior to these versions:

You can do this using "^p" as the CR/LF - UltraEdit translates the ^p into a hard return. You can also use the contents of the clipboard or selected text in a search or replace string with "^c" and "^s" respectively. You can copy/select a string up to 1000 bytes for use this way.

Why does Find Next (F3) not find selected/highlighted text anymore although the appropriate configuration setting is set?

Usually when you see this behavior it is because the "Regular Expressions" checkbox has been checked in the Search -> Find dialog box.

By design, UltraEdit will not search for a highlighted word when "Regular Expressions" is checked in this dialog. Instead, with "Regular Expressions" checked, UltraEdit will search for the last string entered into the "Find What" dialog. This is so that you can continue to use F3 to find different strings that match the original regular expression throughout the file.

How can I keep UltraEdit from creating a new blank file on startup?

Please go to Advanced -> Configuration -> Editor -> New File Creation and ensure that "Create new EDIT file when opening with no other files" is not selected.

Why is the UltraEdit window not moving to background when switching to another application, for example with Alt+Tab?

Please go to the View menu and ensure that Always On Top is NOT enabled. If Always On Top is enabled the UltraEdit/UEStudio window will always appear in the foreground on top of other application windows, even on application focus change, instead of moving to background when switching to another application, for example with Alt+Tab.

How can I modify the list of file types in the File -> Open dialog?

Click on Configuration in the Advanced menu and click on the File Types branch/tab. This page allows the list of file types that appear in the File Open and File Save As dialog boxes to be configured. Up to 10 file types may be configured. The first extension for these file types will be shown in the file operation dialog boxes in the same order they are shown on this page.

Why aren't FTP files reloaded with a project?

Reloading of FTP files is not enabled by default due to the time it can take to download files via FTP. However, if you do want UltraEdit to do this, please go to Advanced -> Configuration -> File Handling -> Load and select "Reload FTP files when reloading a project or last open files".

Why does it take a long time to open large files on some systems?

Regarding large files, UltraEdit handles files in excess of 4GB. UltraEdit is disk based. This means it only loads small portions of the file at once into memory so it does not use all the memory and stop other applications from running. However, it does make a temporary copy of the file to achieve this and this can take time for large files.

There are several options you can change to optimize the handling of large files. More information is available at our large file handling power tip.

How can I move my configuration settings to another system?

The recommended way of doing this is by going to Advanced -> Backup/Restore User Customizations.

Why aren't the help files available? I go to Help -> Index but get a "page not found" or "navigation cancelled" error.

Did you install UltraEdit to the network? If so, there is a known issue in which Windows will not display a compressed .chm (help) file when it is accessed across a network.

If you copy the .chm file (help file) to your local system, you should be able to access it.

Can I use a config file with HTML Tidy in UltraEdit?

You can use a configuration file with HTML Tidy.

Version 11.00 and later:

Specify a configuration file before you run HTML Tidy (tidylib.dll or idm_tidylib.dll) in the HTML Tidy dialog.

Prior to v11.00:

Edit the uedit32.ini file (normally in the %APPDATA%\IDMComp\UltraEdit directory) and under the [Settings] section add:

Html Tidy Config File="fully qualified filename in quotes"

This setting specifies the full path and filename of the configuration file to be used by HTML Tidy (htmltidy.dll). Normally this setting is not used and HTML Tidy uses the default configuration.

Where can I find additional wordfiles for syntax highlighting in UltraEdit?

Additional wordfiles as well as tag lists, auto complete files, and macros are available under Downloads.

How can I print syntax highlighting?

From the File menu, select "Print Setup/Configuration" and then "Page Setup". Here you will see an option to "Print Syntax Highlighting".

Can inner-level folds remain collapsed after expanding an outer-level fold that has been collapsed with "Collapse All"?

This is not currently possible with the "Collapse All" function. However inner-level folds are preserved when they have manually been collapsed within an outer-level fold.

How can I quickly select large portions of text in UltraEdit?

You can select large blocks with the Select Range dialog in the Edit menu. Additionally, here are a couple of methods for making this easier. If you position your cursor at the beginning of a block and move to the end of the block using the scrollbar and press Shift and then position your cursor appropriately the entire block will be selected.

Alternatively, you could position your cursor at the beginning of the block to be selected and, if there is unique text at the end of your block, you could do a Find. When you press Find Next, hold the Shift key and all text between the current cursor position and end of the found text will be selected.

How can I remove lines that contain a particular string?

You can replace lines containing a string with a regular expression Replace All. (Make sure "UltraEdit style Regular Expressions" are selected from the Advanced -> Configuration -> Search -> Regular Expressions Engine dialog or select "UltraEdit" from the "Advanced" section of the replace dialog.)

To do this you would do a find of:

Find What: %*YOUR STRING*^p
Replace With: (literally nothing)

The Regular Expressions section in the Help file has further details and examples are available online in the Power Tips section of our site.

Why does UltraEdit open some files in hex mode?

When a file is loaded UltraEdit checks the first 7K of the file, and if it contains more than two null (Hex 00) the file is considered a binary file and therefore displayed in hex mode.

Currently it is not possible to override the detection of binary files (you can press CTRL + H to escape hex mode). We have had requests for this in the past, and this is something the developers may include in a future release. This is actually a safety measure UltraEdit and UEStudio take - binary files are automatically opened in hex mode to prevent ASCII editing of the file, which could cause nulls to be converted to spaces if UltraEdit is not configured to handle this properly. This could lead to corruption of your file; for instance, if it is a Unicode file with no BOM.

One possible solution is to create a macro, then set it to run every time a file is loaded, using the Set Macro for File Load/Save option under the Macro menu. Your macro would contain one simple command:

HexOff

...automatically disabling hex mode if it is enabled (if it is not enabled, the command won't change anything). Make sure when setting the macro to execute on load that you change the "# of times" to 1.

How can I copy the hex values from UltraEdit to a regular ASCII file?

You can use "HEX Copy Selected View" under HEX Functions in the Edit menu to do this.

How can I keep a paragraph reformat from breaking hyphenated words?

Please go to Advanced -> Configuration -> Editor Display -> Formatting and ensure that "Break on hyphen (-) when converting/reformatting paragraphs" is not selected.

How can I get rid of the "Open Files" title bar above the file tabs?

The "Open Files" bar allows you to click and drag your file tabs to any position on your screen that you want. You can disable this by going to Advanced -> Configuration -> Application Layout -> File Tabs -> Operation and unchecking "Dockable". This will, however, "fix" your file tabs, making them statically positioned at the top of the editor.

My File Tabs have disappeared. How can I bring back the Open File Tabs when they are not displayed anymore?

The easiest way to bring back Open File Tabs is to go to View -> Views/Lists -> and select "Open File Tabs."

How do I keep lines from wrapping at 4096 bytes?

UltraEdit does allow longer line lengths. Under the Advanced -> Configuration -> Editor Display -> Miscellaneous you can change the value of "Maximum columns before line wraps" to 20,000.

This setting sets the maximum columns allowed within UltraEdit before it wraps the line (soft wrap). The default is 4096 columns but a maximum of 20,000 is allowed. Some video drivers have a problem when this is set too high.

Why does the ruler in UltraEdit start with a 0?

The ruler works as a normal ruler would, showing "0" as the start point, allowing the user to measure the number of columns prior to a given point. The status bar, on the other hand, is intended to show the column in which you're about to make an entry. As with normal Windows applications, both of these modes of indication and measurement are, I believe, the standard way of doing things, however, most applications do not include both.

If you prefer to have the ruler begin with "1" rather than "0" please go to Advanced -> Configuration -> Editor Display -> Miscellaneous and select "Start ruler numbering at column 1".

How do I keep UltraEdit from changing permissions when it saves a file?

Please go to Advanced -> Configuration -> File Handling -> Advanced and select "Copy file instead of using rename when creating backup file".

How do I turn off the yellow or light blue line?

In UltraEdit v20 and later, you can disable active line highlighting in View -> Themes -> Manage Themes. Click on the "Editor" tab and uncheck "Enable Active Line Highlighting".

For all versions prior to 20, the active line highlighting can be turned off under Set Colors in the View menu.

Why can't I add words to the spell checking dictionary?

The "add" feature is only enabled if you have specified a custom dictionary to add the words to. In the spell checking dialog, click on "Dictionaries" and select a new file or add an existing file as the custom dictionary and this should work.

You can do this from the Advanced menu and Configuration also if you select the Spell Checker settings and select Dictionaries button.

You can't add words to the language dictionary provided, it is compressed. You have to create a new dictionary file with the NEW button or use an existing one.

Why can't I change the font or size of certain words in a file in UltraEdit?

To add different fonts and styles for different portions of the text would require that the font/style information be saved in the text file with the data. As a text editor, UltraEdit does not add any additional information to the file.

Why can't I delete/rename a directory after editing and closing a file in it?

When you use the File Open dialog to open a file it sets the current directory for the process to the directory you browse to. As this directory is now the current directory you cannot delete it. If you use the File Open dialog to browse to another directory you will be able to delete the previous directory.

Why does copy and paste sometimes stop working?

UltraEdit supports multiple clipboards and sometimes users have activated one of the user clipboards without being aware of doing so.

The clipboards are activated from the Edit Menu, Right Click Menu or Ctrl+0 - Ctrl+9 with Ctrl+0 being the standard clipboard. The active clipboard is shown in the status bar following the line/col separated by a comma. C0 reflects the Windows Clipboard and C1-9 the user clipboards.

If this is not the issue, then you may have enabled the setting to automatically copy selected text. Please go to Advanced -> Configuration -> Editor -> Miscellaneous and make sure that the option "Automatically copy to clipboard when selection is made" is unchecked.

Why don't ClearType fonts display well in UltraEdit?

Note: Since UE v16.20/UES v10.20, ClearType font rendering is automated, and there should not be any issues with font rendering in these or later versions of UltraEdit/UEStudio.

For anyone using a version prior to those listed above, there is an option under Advanced -> Configuration -> Editor Display -> Advanced that can help with the display of ClearType fonts. Please ensure that "Setting this may improve display issues with ClearType fonts on Windows XP" is selected.

Why can't I access my mapped network drives in UltraEdit?

This can occur if UltraEdit is running as administrator. Mapped network drives are not available in any application if it is running as administrator. This is a standard security behavior of Windows UAC. You can check this by right-clicking on both the shortcut you use to launch UltraEdit and the actual uedit32.exe program file within the UltraEdit installation directory. For both of these, select "Properties" then click the "Compatibility" tab. Make sure nothing is set here, especially the "Run this program as an administrator" option.

IDM Highlights newsletter

Sign up now for...

  • Software Powertips
  • New Releases
  • Update Notices
  • Cool Tools, Specials
  • Company News

Free UltraEdit toolbar

Free UltraEdit toolbar

A browser toolbar for IE or Firefox with UltraEdit and UltraSentry integration!