IDM Computer Solutions frequently asked questions

If you do not see your question here, and you are unable to find an answer in our power tips, or by using the search box, please email us with your question.

Do I need to uninstall UltraEdit before installing an update or upgrade?

No, the update will install the new version over top of the existing version, replacing it. Your settings will remain intact.

How can I download a previous or older version of UltraEdit?

Access to previous versions of UltraEdit (and other IDM applications) is currently only available through email. Please email us at support@ultraedit.com with your most current license information, and we will provide you with the version you are eligible for.

How can I delete blank lines in UltraEdit?

As of UltraEdit v24.20.0.40 and UEStudio v17.20.0.10, you can delete blank lines by going to the Edit tab and clicking Delete » Delete all empty lines.

How can I delete blank lines with blank tabs/spaces in UltraEdit?

As of UltraEdit v24.20.0.40 and UEStudio v17.20.0.10, you can delete all empty and whitespace lines by going to the Edit tab and clicking Delete » Delete all empty and whitespace-only lines.

I click "Yes" to the conversion prompt to convert from Unix/Mac to DOS when I open a file, yet the file conversion does not seem to work completely or at all. Why is this occurring?

UltraEdit only converts the file if it is edited and then saved. Also, if you have "Save file as input format" selected in the Advanced configuration menu, the conversion is overridden on save.

The primary purpose behind the automatic/dialog-prompt conversion on file open is to allow the Windows clipboard to function properly. With conversion enabled, a copy or cut operation will include DOS line endings (0D 0A), which allows for seamless use of Unix/Mac files in a DOS environment. The easiest way to get intuitive behavior is to disable the "Save file as input format" option.

How can I configure UltraEdit to create only Unix format files?

You can access this setting by going to Advanced » Settings » File Handling » DOS/Unix/Mac Handling. Select "unix" as the "Default file type for new files".

Why does Find Next (F3) not find selected/highlighted text anymore although the appropriate configuration setting is set?

Usually this is because the "Regular expressions" checkbox has been left checked in the Find box. If regular expressions have been enabled, the default behavior of F3 is overridden so you can continue to use F3 with a regular expression which may match and highlight many different words.

How can I keep UltraEdit from creating a new blank file on startup?

Go to Advanced » Settings » File handling » Miscellaneous and ensure that "Create new Edit file when opening with no other files" is not selected.

How can I modify the list of file types in the File » Open dialog?

Go to Advanced » Settings » File Types. Here you can configure the filter of file types that appear in the "Open" and "Save as" dialogs. You can set up to 10 file types, and each may have multiple extensions (separated by a semicolon).

Why aren't FTP files reloaded with a project or on startup?

Reloading of FTP files is not enabled by default due to the time it can take to download files via FTP. However, if you do want UltraEdit to do this, you can go to Advanced » Settings » File Handling » Load and select "Reload FTP files when reloading a project or last open files".

Why does it take a long time to open large files on some systems?

Regarding large files, UltraEdit handles files in excess of 4GB. UltraEdit is disk based. This means it only loads small portions of the file at once into memory so it does not use all the memory and stop other applications from running. However, it does make a temporary copy of the file to achieve this and this can take time for large files.

There are several options you can change to optimize the handling of large files. More information is available at our large file handling power tip.

How can I move my configuration settings to another system?

The recommended way of doing this is by going to Advanced » Backup settings » Backup/Restore User Customizations.

How can I print syntax highlighting?

Go to File » Print » Print setup » Page setup. Here you will see an option to "Print syntax highlighting".

How can I quickly select large portions of text in UltraEdit?

You can select large blocks with Select » Select range in the Edit tab. Additionally, here are a couple of methods for making this easier. If you position your click at the beginning of a block of text and move to the end of the block using the scrollbar, then press Shift and click at the end of the block, the entire block will be selected.

Alternatively, you could click at the beginning of the block to be selected and, if there is unique text at the end of your block, you could do a Find. When you click Next, hold the Shift key and all text between the current cursor position and end of the found text will be selected.

How can I remove lines that contain a particular string?

One solution is to use the "Delete lines containing string" script, available for download on our scripts page.

You can also replace lines containing a string with a Perl regular expression replace. Press Ctrl + R to open the Replace dialog. Check the "Regular expressions" option and ensure "Perl" is selected in the drop down beneath. Set the "Find what" string to:

^.*YOUR_STRING.*\r?\n?

...and leave "Replace with" empty. Click Replace all to delete all lines containing "YOUR_STRING".

Learn more about Perl regular expressions

Why does UltraEdit open some files in hex mode?

When a file is loaded UltraEdit checks the first 7K of the file, and if it contains more than two hex nulls (hex 00 byte) the file is considered a binary (non-text) file. Nulls are not valid in plain text files, and so UltraEdit will open the file in hex mode. You can prevent this behavior by going to Advanced » Settings » Editor » Hex mode and unchecking "Open files containing hex 00's (nulls) in hex mode".

How can I copy the hex values from hex mode into a regular ASCII file?
Go to Edit » Copy selected (in the "Hex mode" group) to do this.

How can I keep a paragraph reformat from breaking hyphenated words?

Go to Advanced » Settings » Editor Display » Formatting and ensure that "Break on hyphen (-) when converting/reformatting paragraphs" is not selected.

How do I keep lines from wrapping at 4096 characters?

UltraEdit does allow longer line lengths. Go to Advanced » Settings » Editor Display » Miscellaneous and change the value of "Maximum columns before line wraps" to 20,000 (the maximum allowed).

Why does the column ruler in UltraEdit start with a 0?

The ruler works as a normal ruler would, showing 0 as the start point, allowing the user to measure the number of columns prior to a given point. The status bar, on the other hand, is intended to show the column in which you're about to make an entry. As with normal Windows applications, both of these modes of indication and measurement are the standard way of doing things, however most applications do not include both.

If you prefer to have the ruler begin with 1 rather than 0, go to Advanced » Settings » Editor Display » Miscellaneous and select "Start ruler numbering at column 1".

How do I prevent UltraEdit from changing permissions when it saves a file?

This is typically related to backup creation. To prevent this, go to Advanced » Configuration » File Handling » Advanced and check "Copy file instead of using rename when creating backup file".

How do I turn off active line highlighting?

Go to Layout » Themes » Manage themes. Click the "Editor" tab in the "Manage themes" dialog and uncheck "Enable active line highlighting."

Can I change the font, style, color, or size of certain words in a text file using UltraEdit?

To add different fonts and styles for different portions of text in your file would require that the font/style information be saved in the text file with the data. UltraEdit is a plain text editor and does not add any additional information like this to the file. This is within the scope of a word processer like MS Word, but not a plain text editor.

Why does copy and paste sometimes stop working?

Typically when this happens, the user has inadvertently activated one of the user clipboards without realizing it. UltraEdit supports multiple clipboards, and the clipboards are activated from the Edit menu, right-click (context) menu or via Ctrl+0 - Ctrl+9, with Ctrl+0 being the standard (Windows) clipboard. The other 9 clipboards will work only in UltraEdit.

The active clipboard is shown in the status bar following the line/col separated by a comma. C0 reflects the Windows Clipboard and C1-9 the user clipboards.

If you find that this is happening a lot, you can remove the Ctrl+# key mapping assignments for the user clipboards by going to Advanced » Settings » Key mapping and removing the existing assignments for User Clipboard 1 through User Clipboard 9.